Standalone

This document describes prerequisites for the Standalone version of MicroPerimeter™ Security.

Prerequisites

Hardware

Before installing MicroPerimeter™ Security make sure that your machine fulfills the minimum hardware requirements:

Type Minimum Recommended
CPU 2 x 2.60GHz with native 64-bit support 4 x 2.60GHz with native 64-bit support
Memory 6 GB 12 GB
Hard drive free space 8 GB 20 GB
Network connection 100 Mbps 1000 Mbps

Software

Supported operating systems:

  • Linux
  • MacOS

Before you can install MicroPerimeter™ Security following software must be installed on the target machine:

You will need docker-engine and docker-compose running on your environment.

You need to install the exact version specified above!

MicroPerimeter™ Security software can check if you installed the correct version of the necessary software. After downloading and unzipping MicroPerimeter™ Security in terminal navigate to unzipped package e.g.:

cd /home/usr/microperimeter

Go to the standalone directory:

cd standalone

You can verify the software prerequisites by running:

./bin/verify_prerequisites.sh

The output of the above command will provide you with information if you have correct versions of the necessary software.